danielhv 87 microsquirt project

Sep 6, 2018
35
0
6
36
Forney, TX
#1
I feel like I'm just going in circles with my Microsquirt / Tunerstudio setup. Do we have anyone that knows the ins and outs of this? Trying to get idle setup correctly.

Ive got my spark and fuel table flattened out in the idle areas while I try to work this out, and will smooth it once I'm certain it's idling properly.

Here is my latest log, and tune.

Log: https://drive.google.com/open?id=13O...ty5ICFspn_3orB


Tune: https://drive.google.com/open?id=1yS...nez0gzl_88shUG


Car is an 87GT, V3 @ 10psi, AFR185's, Systemax 2, E cam, 4r70w, 42lb Bosch Green Giants
 
  • Sponsors (?)

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#2
Lets start with the basics before i dive into the software, are you trying to get the car to idle in warm up mode or Closed loop?
what is your AFR while idling?
how much timing are you running while idling?

lets start with these and see what we come up with. Thats a very common combination i have tuned many times
 
Sep 6, 2018
35
0
6
36
Forney, TX
#3
Lets start with the basics before i dive into the software, are you trying to get the car to idle in warm up mode or Closed loop?
what is your AFR while idling?
how much timing are you running while idling?

lets start with these and see what we come up with. Thats a very common combination i have tuned many times
I have the IAC valve disabled for now. AFR is in the 13.8 range, base idle is at 10, and my timing table for idle is at 18.
 
Sep 6, 2018
35
0
6
36
Forney, TX
#6
Well everyone up to this point is saying 850 - 900. It's smoother up around 1000 or so, but I'm not sure what's best.
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#7
800 is about as low as that cam will like to idle, I suggest trying this for now....

try this setting and report back, what this will do is create a constant feedback loop for the timing to control the idle speed.


adaptive settings.PNG
adaptive settings table.PNG



now if you are using warmup mode, you will need to change the 'idle advance on' setting to rpm, then setup the table as i have it below.
adaptive settings table rpm.PNG
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#9
yes i can see the rpmdot come down. Now that is a tool you have to get the idle to come in line.

the idle looks fairly stable for the E303, now i suggest you turn on CL idle. these settings are difficult to pin down right off the bat so be patient. dont forget to setup the cl idle rpm curve. Use the basic function and set the sensitivity slider to 1200
you will also need to change the above idle correction advance to the way i had it set in the first two pictures.

do all of this and report back with a datalog,
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#12
Ok the curve is high set it for 1200 far left and 900 far right and smooth inbetween.

something is wrong with the adaptive idle settings or the table it was adding a constant 10* timing to the curve. 28* total will make it idle high
 
Sep 6, 2018
35
0
6
36
Forney, TX
#13
I'm a timing newb. Could the 10 be the base timing set at the distributor?
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#15
no i am looking at the datalog, the software already takes the 10* from the distributor into account.

notice in the datalog i have
SPK: spark advance = this is the total timing the engine is seeing with all the timing trim tables taken into account
SPK: idle advance = the current idle advance adder this can be seen as a positive or negative number

danielhv.PNG

dont mind the tune file loaded in on the right it is from a car i am tuning with MAF
 
Sep 6, 2018
35
0
6
36
Forney, TX
#16
i see, where is that set at? I don't recall ever adding anything like that.
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#18
yeah you did, thats the idle advance table i had you setup in post #7. did you go back into the settings and change them to how i have them in the first two photos?
 
Sep 6, 2018
35
0
6
36
Forney, TX
#19
Ah, I think I see what I did. I mixed the two windows up, didn't realize they were different.

Fixed the adaptive advance timing table... but my idle rpm advance timing option is greyed out.
1536252921382.png
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
6,898
4,065
204
29
Hillsborough county
#20
thats correct you will now use the adaptive advance option that is selectable and set it up like the 2nd photo in post #7