Ego Control setting for megasquirt with AEM wideband

HemiChall

New Member
Dec 27, 2019
9
0
1
50
Western Wisconsin
Looking for help/option with settings on megasquirt pnp ego control tab... The picture attached is default setting on my setup. Just surprised not adjustment below 160 degrees.
89 mustang 302 with b cam...
Thanks!!

EGO control.png
 
  • Sponsors(?)


a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,647
5,725
204
31
Hillsborough county
Set the adjustment so it coincides with the wue ending, 160* is normal as most efi engines run at 200* under running conditions.
Run 5-8% authority settings in advanced mode
P=45
I=20
D=3
Give this a try and see how it does.
 

HemiChall

New Member
Dec 27, 2019
9
0
1
50
Western Wisconsin
Set the adjustment so it coincides with the wue ending, 160* is normal as most efi engines run at 200* under running conditions.
Run 5-8% authority settings in advanced mode
P=45
I=20
D=3
Give this a try and see how it does.
Thank you!!!
This maybe a dumb question but what do you mean by "Run 5-8% authority settings in advanced mode"
Thanks again!!
 

HemiChall

New Member
Dec 27, 2019
9
0
1
50
Western Wisconsin
Just warmed car up with tune today.... Seems good. Will know more in the spring!
Still working on initial cold start up setting...
Thanks again a91what!!
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,647
5,725
204
31
Hillsborough county
I am without a PC right now to look at logs. Bump the cranking pw slightly and see if it helps, if it persists slightly increase the ase% (3-8%) in the temp that the issue is occurring
Rinse repeat until you get the start you want.