Knocking At Passenger Side Front Tire

1989LXFOX

Active Member
Jan 19, 2018
54
13
28
40
Hello all,

I have eiback lowering springs so the car has been dropped about 1.5". When ever I hit a bump I hear a knocking coming from the passenger side front tire. I also noticed that the tire there rubs and knocks when someone is sitting in passenger side. I have caster camber plates too. Any ideas? I am sure its something simple.
 
  • Sponsors(?)


Mustang5L5

i'm familiar with penetration
Mod Dude
Feb 18, 2001
33,929
10,214
224
Massachusetts
Front of control arm.

You can see the sway bay end link here in front of the blue coil spring. Steering rack is not connected to the spindle in this photo.
DSC_0543.JPG
 

1989LXFOX

Active Member
Jan 19, 2018
54
13
28
40
That’s perfect. I really appreciate you taking the time to show me that. I’ll check it out.
Front of control arm.

You can see the sway bay end link here in front of the blue coil spring. Steering rack is not connected to the spindle in this photo.
DSC_0543.JPG
hats per
 

1989LXFOX

Active Member
Jan 19, 2018
54
13
28
40
Front of control arm.

You can see the sway bay end link here in front of the blue coil spring. Steering rack is not connected to the spindle in this photo.
DSC_0543.JPG
The sway bars look fine. I was told it may be a bad strut. The car had Eibach sportline lowering springs installed (no isolators) and KYB shocks/struts. would like to order new struts, was thinking just SVE struts from LMR since I only drive it once a week, but wasnt sure if I need to look at a certian type of strut becuase of the lowered height of my mustang, will they fit with the springs and BBK camber caster plates etc. Any advice?
 

Dan02gt

10 Year Member
Mar 2, 2003
639
278
113
Greenville, NC
If the struts don't fit tight in your caster/camber plates that can cause a knocking. If you're going to get new ones I would recommend Koni. Also consider adding new isolators while you have it apart.
 
  • Like
Reactions: 1989LXFOX

1989LXFOX

Active Member
Jan 19, 2018
54
13
28
40
I checked the middle bolt on the caster/camber and it was quite loose. I tightened it, I hope thats what it is so I dont have to buy struts! Ill let everyone know once I get a chance to take it out!