Microsquirt timing issues

Hey guys. I'm a beginner with this and I think i've turned myself around so much that i'm not sure how to correct my issue. Any advice would be appreciated. Its an 88 GT with a microsquirt. This is a brand new build for me, so I am working off of the stock tune in the microsquirt. I had it running ok and then all of a sudden it slowly chugged out and died on me. I tried firing it back up, but it was a hard start and it backfired. That was a few days ago. I had it running briefly today, but I couldn't get it to stay running. I believe its an issue with my timing. I have tried to mechanically turn the distributor just to get it started so I can dial it in with the trigger wizard, but I can't even get it to run currently. Attached are a few of my datalogs. The first one is when I had it running for a good amount of time the other day. The next one is when I had it running today for about a minute before it died. The last one is my most recent try to start it. It cranks and sometimes chugs like it wants to turn over, but it won't. Any insight is really appreciated.


  • 2021-07-11_14.42.20.mlg
    5.4 MB · Views: 3
  • 2021-07-13_19.44.46.mlg
    194.9 KB · Views: 1
  • 2021-07-13_20.21.17.mlg
    45.8 KB · Views: 1
  • Sponsors (?)

An .msq (tune file) helps. There are a few different versions of the base tune.
I have found that some of them come with the ign output set to "going high" but this does not seem to trigger the tfi correctly try setting it to "going low" and report back
I’ll give it a shot tonight if I can and I’ll report back. I just replaced my TFI module and my fuel pump. The long tune I posted before was right after I replaced the TFI.

Im very much new to this, but I’m trying to work through it. Thanks for your help with this.
The output was already set to going low. I went into my project and pulled out the file that I believe is the .msq file. I attached it here. I think I have an issue with my wideband gauge and I have to go over the wiring again. I have an AEM x-series 30-0300 wideband gauge. It has power, and I grounded it out to the signal ground (white/black) wire on the microsquirt. With key on, i'm getting a 14.54 reading on the gauge without even starting it. With the key on, the AirFuel Ratio 1 gauge on the computer is showing a 7.3 and constantly bounces at the bottom of the gauge. I also had it running for a few seconds the other day. Attached is the datalog from that session. Any insight is greatly appreciated.


  • crsettings_2021-07-13_19.56.39.msqpart
    1.4 KB · Views: 1
  • 2021-07-13_19.44.46.mlg
    194.9 KB · Views: 0
Ok, so I walked away from this for a little while, and to be honest, didn't feel like picking it back up out of frustration. I pulled apart my a-pillar to trace the wiring for my wideband gauge. It has power (red), I grounded it to a bolt on the chassis (black), The analog +(white) was wired to the 02 pink wire on the microsquirt, and the analog - (brown) was wired to the signal ground on pin 20 on the microsquirt. As I was checking things I decided to take apart the signal ground connection and re-do it, and managed to pull the sensor ground completely out of the harness on the end that goes into the computer harness on my car (FML). Now i'm in the process of figuring out which pin hole that was supposed to go in, as I don't see an empty terminal on the other side of the harness. Aside from that though, I am just about positive that I had this wideband gauge wired up properly. It was registering around 10 or 11 after I tried to fire the car, and a constant 7.3 on TunerStudio. I'm just about stumped on this, and i'm starting to think that it could be the gauge altogether.

I'm fairly certain that I have some of the settings incorrect for my base tune, and its not allowing me to fire the car up. I just replaced the spark plugs with autolite 104s, new motorcraft coil, and i replaced the tfi module. I have 40 PSI at the fuel rail. I've used a noid light to verify that my injectors are working. I'm just not experienced enough to walk my tune back to get it to a point where the car will turn over.

I am able to turn the car over, and it fires, but only if i hold my foot and give it gas, and it dies immediately when I take my foot off. Attached is my most recent data log for the few seconds I had it running and also my msq file. Any help to point me in the right direction is greatly appreciated.


  • 2021-09-21_20.41.36.mlg
    68.8 KB · Views: 2
  • CurrentTune.msq
    118.8 KB · Views: 2
browsing through your file I noticed that under startup/idle > cranking settings you have the cranking value set to 1000... this is way to high reduce this value down to 350. basically the ecu thinks you are constantly cranking the engine over even once it starts to light off, it will never run this way.
Thank you for the quick reply. I will make that change once I’ve figured out the issue with the signal ground on the harness and report back. I also appreciate the offer to help me get the car running. It fired right up first try when I first installed the microsquirt, but I’ve since moved backwards trying to dial it in, which is frustrating to say the least. The plugs I pulled were fouled, and they really weren’t that old. I took a picture of one of them when I pulled them.


  • 77CB8FC8-454F-471A-AD62-5D90333A79B2.jpeg
    308 KB · Views: 7
I got the signal ground sorted out, but I am still having trouble with the gauge output to TunerStudio. Its still stuck at 7.3. I reduced the cranking RPM down to 350 as recommended. On one crank it barely turned over, but sputtered and died. The time was no longer than a few seconds, and the datalog would have been about as long as the one I posted yesterday.
Did you select your wideband under the tools menu to calibrate the input?
A constant low reading can be a incomplete connection as well. I suggest taking a voltage reading at the MS harness by unplugging the ecu and powering the wideband
I calibrated it under custom WB in the drop down. My exact model is not listed, which is strange because I’ve seen videos posted where it was one of the options. The other two AEM products on the drop down do not match what is in the instructions. I calibrated it based off of the scaling table from the instruction manual. I attached a picture.

So what you’re recommending I do is pull the computer, turn the key to on, and verify at the pin that the voltage on the white wire (analog +) matches the voltage for the proper output on the gauge?


  • BBD8403B-794D-46BA-BA8C-32FF5F0904A4.png
    435.5 KB · Views: 5
Ok. I finally got some time to work on this. I was able to get my wideband to register on TunerStudio. It’s about .1 or .2 off, but it’s pretty close. I was getting funky intermittent (but correct) readings from my multimeter, so I just went back and ripped out the analog + wire and started over. I believe that was the problem. It’s too late to try to fire it up, but this is a step in the right direction. I still think the settings need some work.


  • 19AC4264-5944-4276-9938-6615EC95361A.png
    1.6 MB · Views: 2
  • 08A4E853-7525-4CFC-A686-0944E0339B5E.png
    1.1 MB · Views: 2
I’ll read up on how to make that adjustment. I made the rpm adjustment down to 350 like you mentioned. Was there anything else that you’d recommend I change before I try to start it up? I feel like I don’t know where to start for timing. When I had it running, I had it at 20 degrees, I believe per one of your YouTube videos. I don’t know what my offset was, as I’ve changed it to try to get it to fire. Do you have a recommendation for any changes to the table or timing settings to make this easier to get to turn over?
The tfi ignores the ecu during cranking. It will fire at the base advance value or offset (10*)
Set the offset to 10 and lock the timing at 20* to begin. You will then verify 20* at the balancer with a light. You may then switch it over to use table.

As for the timing table most engines will need around 18 at idle, WOT 30 is a good place to start from 2500 and up. In vacuum 50kpa and lower expect to have values from 36 to 45 depending on the build.
I set the settings per the instructions. I couldn’t get it to fire. It cranks and chugs like it wants to turn over, but it doesn’t. The battery is charged, fuel pump primes, 40 PSI at the rail, but no fire. It’s getting fuel because after I try to crank it, the wideband registers a reading. I haven’t pulled my plugs yet to see if they are fouled or not. That’s probably where I’ll go next.