New MSPnP2 in 94 Mustang, need help getting stable idle once warmed up.

lamrith

Founding Member
Jun 7, 2000
1,385
1
38
Tacoma, WA
www.mgbconversions.com
94 Mustang Coupe
393 stroker, XE270HR Cam, 190CC Procomp heads, Speedmaster EFI Intakes, 36# injectors, stock 94 TB with fixed idle screw.

I finally got it so the car will start and idle thru most of warmup. Idle is pretty solid and stable while warming up, but did not get out of warmup enrichment when it died. It start hunting more and more then dies. I had warmup autotune running and had it save a recommended change early on at around 53 seconds which spazzed it out a bit.

Can anyone help? bit over my head here, but hoping to get it to idle all the way thru to reasonable idle so I can start Steve's idle tuning on it. AFR seems a bit low, target are richer than it is running. Around 240 second it really started hunting and I had to open throttle to keep it running. Not sure where to start/attack to get it to idle thru wue and stay stable so I can run the IAC and timing tests.
 

Attachments

  • 2020-06-06_09.51.59.mlg
    1 MB · Views: 29
  • 2020-06-06_10.05.33.msq
    117.3 KB · Views: 27
  • Sponsors(?)


lamrith

Founding Member
Jun 7, 2000
1,385
1
38
Tacoma, WA
www.mgbconversions.com
I was able to get the car thru warmup and to idle at full temp. Open loop idle got it done. I had to watch the PWN and over-ride it when I tried to drop idle too low.

I am however seeing random blips/errors in tuner studio dash/datalogs? I am getting intermitent spikes in registered rpm> It will spike to say 4k or more rpm, but the engine is not increasing rpm at all. IT is causing hiccups though and unstable afr/idle which is problematic.

Here is a link to a datalog showing the rpm spikes. Any thoughts on reason/fix? This is a brand new Distributor, coil, plugs and wires all from RockAuto.
 

Attachments

  • pwm.mlg
    1,006 KB · Views: 24