Engine 1991 5.0 HO ignition problems.

flyboy103

New Member
Jun 6, 2020
2
0
1
63
nh
Hi guys new to site and not sure if this is the right place but here goes. I have a factory five cobra with a 1989 mustang 5.0 HO.i,m having problems with the engine dying after about ten minutes of driving. this has the tfi ignition and i have changed the module with a new rotorcraft one. i also put a new coil in and swapped dizzy,checked all grounds and wiring going back to computer. the car will start if i pull the spout( spark out put jumper) so I'm thinking its the computer. any other thoughts would be greatly appreciated. thanks for reading. no fun when sitting in garage.
 
  • Sponsors(?)


91GTstroked

Active Member
Jun 14, 2007
214
56
38
Verify that the new TFI module isn't junk. I've had new ones bad right out of the box. And they were motorcraft ones. They are more than likely made in China. Rock Auto has 2 year warranty on the motorcraft ones.
 

flyboy103

New Member
Jun 6, 2020
2
0
1
63
nh
hi 91gt ive been thru 4 modules 1 from orileys,2 from motorcraft and 1 was on the dizzy when i swapped that out, so i think i can rule that out. but thanks for reply.totally new to posting and not sure where i am
 

7991LXnSHO

Now I want a 10 year badge
10 Year Member
Sep 1, 2010
3,158
602
164
Kearney, NE
If you have a stock style computer and harness, check for codes before spending more money on parts. If it is a Mustang in disguise, this is a good place to ask for help.
 

jrichker

StangNet's favorite TOOL
SN Certified Technician
Mar 10, 2000
27,279
2,627
234
74
Dublin GA
lowendmac.com
@flyboy103

Dump codes sticky

Look at the top of the 5.0 Tech forum where the sticky threads are posted. One of them is how to dump the computer codes. Codes may be present even if the CEL (Check Engine Light) isn’t on. You don’t need a code reader or scanner – all you need is a paper clip, or if your lady friend has a hair pin, that will do the job.
I highly suggest that you read it and follow the instructions to dump the codes. http://www.stangnet.com/mustang-forums/threads/how-to-pull-codes-from-eec4.889006/


Code 14 - Ignition pickup (PIP) was erratic – the Hall Effect sensor in the distributor is failing. Bad sensor, bad wiring, dirty contacts. Factory tach will sometimes read erratically.

Revised 8-Apr-2017 to correct SPOUT problem symptoms wording

The PIP is a Hall Effect magnetic sensor that triggers the TFI and injectors. There is a shutter wheel alternately covers and uncovers a fixed magnet as it rotates. The change in the magnetic field triggers the sensor. They are often heat sensitive, increasing the failure rate as the temperature increases.

PIP Sensor functionality, testing and replacement:
The PIP is a Hall Effect magnetic sensor that triggers the TFI and injectors. There is a shutter wheel alternately covers and uncovers a fixed magnet as it rotates. The change in the magnetic field triggers the sensor. A failing PIP sensor will often set code 14 in the computer. They are often heat sensitive, increasing the failure rate as the temperature increases.

Some simple checks to do before replacing the PIP sensor or distributor:
You will need a Multimeter or DVM with good batteries: test or replace them before you get started. You may also need some extra 16-18 gauge wire to extend the length of the meter’s test leads.
Visual check first: look for chaffed or damaged wiring and loose connector pins in the TFI harness connector.
Check the IDM wiring – dark green/yellow wire from the TFI module to pin 4 on the computer. There is a 22K Ohm resistor in the wiring between the TFI and the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 22,000 ohms +/- 10%.
Check the PIP wiring - dark blue from the TFI module to pin 56 on the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 0.2-1.5 ohms.
Check the SPOUT wiring – yellow/lt green from the TFI module to pin 36 on the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 0.2-1.5 ohms.
Check the black/orange wire from the TFI module to pin 16 on the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 0.2-1.5 ohms.
Check the red/green wire; it should have a steady 12-13 volts with the ignition switch on and the engine not running.
Check the red/blue wire; it should have a steady 12-13 volts with the ignition switch in Start and the engine not running. Watch out for the fan blades when you do this test, since the engine will be cranking.
If you do not find any chaffed or broken wires, high resistance connections or loose pins in the wiring harness, replace the PIP sensor or the distributor.

The PIP sensor is mounted in the bottom of the distributor under the shutter wheel. In stock Ford distributors, you have to press the gear off the distributor shaft to get access to it to replace it. Most guys just end up replacing the distributor with a reman unit for about $75 exchange

PIP problems & diagnostic info
Spark with the SPOUT out, but not with the SPOUT in suggests a PIP problem. The PIP signal level needs to be above 6.5 volts to trigger the computer to pulse the fuel injectors, but only needs to be 5.75 volts to trigger the TFI module. Hence with a weak PIP signal, and the SPOUT in, you could get spark but no injector pulse. You will need an oscilloscope or graphing DVM to measure the output voltage since it is not a straight DC voltage.

See http://www.wellsmfgcorp.com/pdf/counterp_v8_i2_2004.pdf and http://www.wellsmfgcorp.com/pdf/counterp_v8_i3_2004.pdf for verification of this little detail from Wells, a manufacturer of TFI modules and ignition system pro