Idles Fine, Rev engine High Manually, engine comes down and dies.

DustinMcClintock

New Member
Sep 14, 2020
2
0
1
26
Springfield
I am having an issue with my 1989 Ford Mustang with a 2.3L 4 cylinder.

Car sat for about two years and is a convertible model (don't know if that matters but giving all information i know), i drug the car out this weekend and worked on getting it running. I believe it had roughly a quarter of a tank of gas that has sat for 2 years, I'm here to try and get some help before i sell it.
I got the car running by replacing the starter solenoid, starter itself, new battery and ran sea-foam and octane booster through the engine. I also ran a little bit of sea-foam through the oil and let the car idle for two hours before changing the oil and putting in new oil and oil filter. The problem i am having is weird and never experienced anything like this. The car will idle with no problems, starts up and can sit in idle all day (as long as you add gas), but when i put the mustang in Neutral and rev the engine high it comes down slowly and then sputters and eventually dies, it doesn't have a problem driving at a slow speed 25 or so when not revved, as soon as you rev the engine not sure what I'm hitting as the tachometer doesn't work fully but seems to be in the 4k or 5k range then sputters and dies, but will start right back up and idle no problem. I was told two things and want to verify this: One person said bad fuel and to drain tank and start fresh, the other said possibly the Throttle Position Sensor, just looking for more input on what it could be. I have another issue with Overdrive but i don't think the two are related, overdrive works when the car is cold and will shift into it, but you get into the gear one time and once the car warms up it wont go back into overdrive. Any help would be much appreciated and I'm sure i will be back when working on one of my other mustangs.
 
  • Sponsors(?)