P1131 Code and Rattle Under Throttle

Devon27

New Member
Dec 6, 2019
12
0
1
50
Virginia
So a couple weeks ago I noticed my 00 GT would rattle at around 3000 rpm in certain gears after it warmed up. It was a rattle faint sound coming from the motor that I could feel vibrating the gas petal pretty aggressively. Sounds almost like an exhaust leak and I assumed it was pre-ignition. I did some investigation into the ignition system and didn’t find any clues. I then concluded I had filled up with a bad tank of gas so I ran some cleaner and it went away for a few days.

It is back now and today while driving I got the P1131 code. I assume the issues are related. I’m going to check the usuals, the 02 sensors, vacuum lines, fuel injectors and MAF. Any pointers into what to look into first given the pre-ignition like symptoms? On the first day I noticed it getting real bad I experienced a loss of power on takeoff as well but that went away after after running fuel system cleaner. Could bad O2 or MAF sensors be causing all that?
 
  • Sponsors(?)


Devon27

New Member
Dec 6, 2019
12
0
1
50
Virginia
So a couple weeks ago I noticed my 00 GT would rattle at around 3000 rpm in certain gears after it warmed up. It was a rattle faint sound coming from the motor that I could feel vibrating the gas petal pretty aggressively. Sounds almost like an exhaust leak and I assumed it was pre-ignition. I did some investigation into the ignition system and didn’t find any clues. I then concluded I had filled up with a bad tank of gas so I ran some cleaner and it went away for a few days.

It is back now and today while driving I got the P1131 code. I assume the issues are related. I’m going to check the usuals, the 02 sensors, vacuum lines, fuel injectors and MAF. Any pointers into what to look into first given the pre-ignition like symptoms? On the first day I noticed it getting real bad I experienced a loss of power on takeoff as well but that went away after after running fuel system cleaner. Could bad O2 or MAF sensors be causing all that?
Update: A few hours after the code showed up my car began to surge at idle. And it climbs up to 3000 rpm and hangs then goes down for a few seconds and repeats.