Progress Thread 2003 Ford Mustang GT Build Log

  • Sponsors(?)


03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
rust free gas tank

original fuel pump?

I tried my best to clean the outside before removing the top lid. I wiped the inside of the assembly down with a shop towel and cleaned everything I can reach.

I am currently waiting for the new pump to arrive... its taking the driver a bit longer then expected. I ordered a OEM replacement so I am hoping its plug and play.
 

Attachments

Last edited:

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
rust free gas tank

original fuel pump?

I tried my best to clean the outside before removing the top lid. I wiped the inside of the assembly down with a shop towel and cleaned everything I can reach.

I am currently waiting for the new pump to arrive... its taking the driver a bit longer then expected. I ordered a OEM replacement so I am hoping its plug and play.
P1237 code and car doesn't want to idle. I am going to install the original pump to see if that fixes it. Don't know what the hell is wrong with this car jesus.
 

Attachments

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
Had time today to reinstall the original fuel pump and the codes went away (P1151 active) so car is back to its original running state..

So that means the replacement fuel pump - Delphi FE0443 Electric Fuel Pump was not good. - returning asap


As for the build -
I have contacted a few shops on estimates/quotes for work on the car. If anyone lives near the 77449 TX area and wants to work on my car for cash feel free to PM me.
1.Diagnostic check - seeing if its something simple
2.removing heads
3.probably a engine swap

Online pricing off automotix -
2011 crown vic police pkg 50K miles ($1000) vs 111k 04 gt motor ($2500)


Lastly Iv'e been working on other cars too. 2020 Elantra and a 02 Chevy Suburban - control arm /suspension and tire job. So that gave me a sense of accomplishment lol

Thanks again for viewing. Nothing is final until it is. - I will probably drop the thread for a couple of weeks until a major update.
 

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
MAJOR UPDATE:

purchased 2010 vic block with 89k miles - its already at the shop
my mechanic that I am paying came to pick up my car with his trailer just damaged the whole exhaust system loading it and front bumper
front bumper has 2 nicks into it
the ends on the headers are damaged
the x pipe ripped off and the clamps are all damaged
the o2 sensors are ripped
the mufflers are dented in most likely

mmmm amazing and now I have a new straight headers exhaust system mustang parked out front waiting for his plan B
 

MattMan02GT

Member
Jul 24, 2018
83
8
18
31
Albany, NY
Holy flipping crap! The first part of the major update sounded very promising, but ripping off the exhaust during loading?! Is the car too low for the ramps and trailer he brought? It sounds like an insurance claim for him....
 
  • Like
Reactions: 03GThoopty

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
Holy flipping crap! The first part of the major update sounded very promising, but ripping off the exhaust during loading?! Is the car too low for the ramps and trailer he brought? It sounds like an insurance claim for him....
I know but I ain't going to sweat it. We going to make it work!

new clutch assembly
pulleys
tension-er

thermostat
belt
water pump
main/rear seals/gaskets
oil filter/oil
coolant
transmission fluid
probably missed something but engine is getting even more of a refresh again.

Hoping to get the car tested again by this Saturday.. long tube reinstall is the current obstacle to face again.

we making it work and hopefully will be back soon with no issues!
 

Attachments

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
Finally driving the car!

runs good and new clutch makes it way easier to drive. My car doesn't sound aggressive up until I really step on it at around 3K RPM which I kind of like but also don't haha.

I tried to get the car inspected and 1. the cel light isn't turning on
2. the inspector said the computer wouldn't connect to my computer on my car but my OBD 2 scanner does read and I did have a code but after driving around for a couple of more mins it did go away. (P0153) o2 code.

So I am now going to see if the bulb needs replacing I have a bunch of spares. The inspector recommended me to go to ford. He said it may be a blown fuse or a bad computer.

I am going to check fuses first then check the bulb.
 

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
replaced fuse but didn't fix it so I replaced the bulb with a new led and it works now.

So not too sure why their scanner tool didn't connect to my car. hmm
 

03GThoopty

Member
Jun 14, 2019
63
12
18
Texas
passed inspection and registration is good for the year.

active codes after inspection are : p1151 p1131 p0153 all probably related to the long tube headers and or vacuum leak/LT headers

Iv'e been reading on this and it seems like its a common issue that I will need tuning for the long tube headers/o2 sensors to play nice and pop no codes?

Any recommendations let me know!
 

Attachments